Backpacks Mod (Version in description)

49 likes | 20202 views

Download (6158)





In order to have this mod work, you will need the 1.0.0 version of minecraft and blocklauncher. First install this mod and then go into blocklauncher and make sure its working. Then you will restart the map and go into a world and your done! Not mine. If there is some problems tell me. The version is not really all.




Follow @UTKio Tweet